Lieber Besucher, herzlich willkommen bei: RCLine Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Mittwoch, 7. Februar 2018, 18:39

Taranis X9D+ Motor dreht bei 0 weiter

Hallo Forum, :)

ich bin neu hier und habe schon fleißig gelesen ..., auch die seeehr umfangreiche Anleitung habe ich einmal durch.
Elektrisch habe ich keine zwei linken Hände, was das Programmieren einer Fernbedienung angeht habe ich allerdings überhaupt keine Übung oder gar Erfahrungen.
Mit meiner neuen Fernsteuerung habe ich ein Problem, dessen Ursache ich nicht finden kann:
Wenn ich den Gasknüppel in Nullstellung stelle, dreht der Motor - etwas langsamer als max. - weiter, egal ob vorwärts oder rückwärts.
Schalte ich den Gasknüppel (mit SG-) ab, steht auch der Motor.
Programmiert habe ich folgendes:
Den ersten Mischer auf CH1
QuelleI3:Gas 50% Wichtung, 50% Offset
Schalter SGup - ersetzen
Den zweiten Mischer auf CH1
QuelleI3:Gas -50% Wichtung, -50% Offset
Schalter SGdown - ersetzen

Möglicher Weise hängt das damit zusammen, dass ein Fluggerät nicht mit rückwärts laufendem Motor fliegt und deshalb die Nullstellung des Knüppels verschoben ist. Ich habe aber keine Ahnung, wo ich die Einstellung dazu finde.

Grüße aus Magdeburg
Taste

heikop

RCLine User

Wohnort: Lüdenscheid

  • Nachricht senden

2

Mittwoch, 7. Februar 2018, 19:29

Moin,

was willst Du eigentlich erreichen? Diese Unterscheidung zwischen + und - sowie die Offsets haben in einer Gaskurve für
Flugzeuge nichts zu suchen.

Wenn es nur um den "Sicherheitsschalter" geht sollte das so aussehen:
»heikop« hat folgendes Bild angehängt:
  • Unbenannt.PNG
Grüße,
Heiko

3

Mittwoch, 7. Februar 2018, 19:44

Ergänzung ...

okay, ich habe den Hintergrund vergessen zu erklären:
Das Programm ist für ein Boot.
Dabei soll über den Gasknüppel die Geschwindigkeit geregelt und über den Schalter die Drehrichtung (vorwärts/rückwärts) gewählt werden. Später möchte ich das Rückwärtsfahren in der Geschwindigkeit noch limitieren; die Feinabstimmung hat aber noch etwas Zeit.


Taste

4

Mittwoch, 7. Februar 2018, 19:47

Noch nicht ganz verstanden (auch nicht nach der Erklaerung).
Warum Schalter? Das sollte doch auch alleine mit dem Gasknueppel gehen. Mittelstellung waere dann 0.
Gruss
Thomas
🖖
No sé donde voy. pero estoy seguro de que yo llegue.

Daesh no tenim por!!!

5

Mittwoch, 7. Februar 2018, 20:13

Ich möchte die Richtung (vor/zurück) statt mit dem Knüppel mit dem/einem Schalter festlegen. ;)
Das muss man nicht mögen aber es müsste doch möglich sein(?).

6

Mittwoch, 7. Februar 2018, 20:47

Das hiesse aber das wenn du gerade Vollgas faehrst und den Schalter umlegst es ein abrupptes Bremsen gibt. So geplant?
Gruss
Thomas
🖖
No sé donde voy. pero estoy seguro de que yo llegue.

Daesh no tenim por!!!

7

Mittwoch, 7. Februar 2018, 21:11

Also ich bin nicht so fit mit der Taranis (also OpenTX).
Aber hast du nicht den Mischer im Grunde genommen verkehrt rum?
Eigentlich willst du doch auf den Schalter den Gasknueppel dazumischen (addieren).

Jetzt muessen die OpenTX Experten ran. Ohne den Sender zu haben bin ich da aufgeschmissen.
Gruss
Thomas
🖖
No sé donde voy. pero estoy seguro de que yo llegue.

Daesh no tenim por!!!

8

Mittwoch, 7. Februar 2018, 21:46

Taste so wie du es schreibst ist es völlig in Ordnung, wobei es bei dir egal ist, ob du Addieren oder ersetzen machst
Hast du mal im Kanalmonitor geschaut, wie die Ausgabe ist?
Auf der normalen Taranis Oberfläche die "Page" taste, bis du die Kanäle und die aktuellen Ausgabewerte sehen kannst

Thomas es ist egal, da mit dem Schalter die Mischerzelle deaktiviert wird, wichtig ist ersetzen, wenn mehrere aktiv sein könnten, dann kannst du mit ersetzen ein Priorisieren

9

Mittwoch, 7. Februar 2018, 22:16

Danke. Verstanden. Ist nicht einfach nur mit Theorie und Handbuch. :D
Aber die +/- 50 Prozent leuchten mir gar nicht ein.
Gruss
Thomas
🖖
No sé donde voy. pero estoy seguro de que yo llegue.

Daesh no tenim por!!!

10

Mittwoch, 7. Februar 2018, 22:54

Du meinst mit Kanalmonitor die Simulation?
Ja, dort habe ich geschaut - da passt alles. Gibt es irgendwelche Paramater, die einen Einfluss haben können, die ich in der Simulation aber nicht sehe? ???
Können unpassende Firmwareversionen dazu führen (müsste ich prüfen, ob das überhaupt in Frage kommt)?
@Thomas_R.: Ich bin noch nicht so weit, dass ich meine Programmierung erklären kann - ich verstehe es gerade selber, wenn ich mich damit intensiv befasse. Für mich ist das absolutes Neuland! Ich arbeite daran.
Schon mal ein Dankeschön! Vielleicht ist der Fehler ja noch zu finden, ich bin morgen wieder hier ... zzz
Taste

11

Mittwoch, 7. Februar 2018, 23:03

Ich noch mal:
Nein, Du meinst nicht die Simulation!
Wenn ich den beschriebenen Kanalmonitor direkt auf der Taranis anschaue, bleibt der Wert wenn der Knüppel ganz unten ist bei 22,7 (vorwärts) bzw. -22,7 (rückwärts) hängen. Auch wird die 100 (vorwärts und rückwärts) schon erreicht, wenn der Knüppel in Mittenposition (also quasi neutral) steht.
In der Simulation sieht das anders aus. Was ist der Unterschied zwischen der Simulation und dem Kanalmonitor?
Die Ursache habe ich damit noch nicht gefunden, ich kann sie aber vielleicht einfacher finden, wenn ich den Unterschied zwischen Simulation und Kanalmonitor kenne.
Taste

12

Donnerstag, 8. Februar 2018, 13:58

Zwischendurch mal eine ganz andere Frage (an die Spezialisten):
Die Taranis X9Rplus hat eine Firmware und Daten auf der SD-Karte.
Dann fällt besonders in Fehlermeldungen der Begriff EEPROM.
Bis eben dachte ich noch, zumindest diesbezüglich den Durchblick zu haben. Das scheint aber nicht so zu sein.
Wo bekomme ich aktuelle und zueinander passende Daten für die Firmware und die SD-Karte für die X9Dplus?
(Das was ich im Netz finde wird mir bei der Verarbeitung als alt angegeben.)
Taste

heikop

RCLine User

Wohnort: Lüdenscheid

  • Nachricht senden

13

Donnerstag, 8. Februar 2018, 16:06


Wo bekomme ich aktuelle und zueinander passende Daten für die Firmware und die SD-Karte für die X9Dplus?



Hier: http://www.open-tx.org/2017/12/16/opentx-2.2.1
Grüße,
Heiko

14

Freitag, 9. Februar 2018, 07:40

Wenn du dem Englischen mächtig bist hilft die Seite https://open-txu.org/ ungemein weiter.
Ich würde auch empfehlen, dass du deine Firmware und SD Karteninhalten auf Stand bringst (Achtung: Es kann sein, dass du dann ev. auch deine Empfänger updaten musst)

Von der Programmierung wäre noch interessant wie deine entsprechender Eingangswert aussieht (I03). Geht der auch tatsächlich von -100% bis +100%. Klingt zwar vielleicht etwas blöd, aber deine Sticks sind richtig kalibriert?

Verstehe ich das richtig, dass du im Mixer Ch1 Gewichtung 50% und 50%Offset hast?

Edit: Was meinst du mit, im Simulator sieht das ganz anders aus?
mfg
Andreas

15

Samstag, 10. Februar 2018, 13:26

Sorry, vielleicht stelle ich mich blöd an ... ==[]
Ich habe jetzt den Sender und die SD-Karte „geupdatet“. Jetzt bekomme ich eine Fehlermeldung (siehe Bild).
Was mache ich falsch?
Taste

16

Samstag, 10. Februar 2018, 13:36

Ist doch nur ein Hinweis das das EEPROM upgedated wird.
Und du deine Daten die da gespeichert sind vorher sichern kannst. Weil nach dem Update werden sie wohl weg sein.
Gruss
Thomas
🖖
No sé donde voy. pero estoy seguro de que yo llegue.

Daesh no tenim por!!!

17

Samstag, 10. Februar 2018, 13:51

Aber da passiert nichts. Was muss ich tun, damit das Update auch tatsächlich durchgeführt wird?
Ich habe das schon mehrfach durchgespielt ...

18

Samstag, 10. Februar 2018, 14:14

Ich weiss ja nicht was du genau gemacht hast. Aber hier die Anleitung sollte auch bei dir gehen.
https://www.propwashed.com/update-frsky-taranis-firmware/
Gruss
Thomas
🖖
No sé donde voy. pero estoy seguro de que yo llegue.

Daesh no tenim por!!!

heikop

RCLine User

Wohnort: Lüdenscheid

  • Nachricht senden

19

Samstag, 10. Februar 2018, 20:24

Aber da passiert nichts. Was muss ich tun, damit das Update auch tatsächlich durchgeführt wird?
Ich habe das schon mehrfach durchgespielt ...


Da passiert auch nichts weiter, die alten Modell- und Einstellungsdaten werden in das neue Speicherformat konvertiert,
das ist alles. Danach unter neuem Namen speichern, und die Daten sind für OpenTx 2.2.1 vorbereitet.

SD-Karte aktualiseren (siehe mein Link), OpenTx 2.2.1 auf den Sender flashen, Sender ausschalten, "neue"SD-Karte rein,
Sender einschalten.

Wenn noch alte Modelle im Senderspeicher sind werden die auch aktualisiert, ansonsten die neu gespeicherte Modelldatei
auf den Sender packen und das war's.

Aufwändiger wird es nur wenn man z.B. von einer X9D auf eine X10S umsteigt, da muß dann an den Modelldaten einiges geändert werden,
aber ein simples Update wie bei Dir sollte in 5-15 Minuten erledigt sein.
Grüße,
Heiko

20

Sonntag, 11. Februar 2018, 22:38

Gelöst ...

:applause:
So, ich habe mein Problem in den Griff bekommen:
Man muss sich ordentlich einlesen!
Beim Installieren von Companion muss man auf die einzelnen Versonen aufpassen. Einmal zurück auf die Vorversion und anschließend wieder auf die aktuelle hat bei mir auf dem Rechner (Win7) Probleme bereitet. Erst nach der Säuberung der Registry lief es wieder.
Nach erfolgreichem Aktualisieren und mehrfachem Kalibrieren der X9D+ ging dann auch das Übertragen von Modellen vom PC in den Sender (wobei das Kalibrieren dafür wohl eher nicht entscheidend war).
Der Motor läuft jetzt wie er soll und ich kann weiter basteln ...
Herzlichen Dank an die Helfer! ;)
Gruß, Taste
:w