Lieber Besucher, herzlich willkommen bei: RCLine Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Schmidti

RCLine User

  • »Schmidti« ist der Autor dieses Themas

Wohnort: Bad Oeynhausen ____MSV Espelkamp____

Beruf: Kfz-Mechanikermeister

  • Nachricht senden

1

Sonntag, 29. April 2007, 11:22

Drehzahlmesser

Hi

Ich möchte mir einen unniversellen Drehzahlmesser bauen. Dieser soll spätermal über eine Feldspule den Zündfunken abtasten, sowie über eine Optik als auch über einen Drehgeber Drehzahlen erfassen können. Mega8, Optokoppler und Lcd. Da der Optokoppler einen N-P-N-Transistorausgang hat, habe ich am ICP1-Pin einen Pull-Down-Widerstand verbaut und löse so den Interupt aus. Alle anderen inho freien Pinne sind Eingänge mit aktivierten Pull-Up. Programmiert habe ich mit Bascom und das Prog läuft mit 4Mhz und 16Bit-Timer. Abgeglichen habe ich das Prog mit einem Frequenz-Generator am PC. Das Prog läuft an diesem Generator ohne Probleme über den gewünschten Messbereich <250Hz und zeigt auch die entsprechende Drehzahl an. Allerdings wird hierbei der Optokoppler nicht über eine Feldspule, sondern direckt über das Lautsprecherkabel und Vorwiderstand gefüttert.

Heute habe ich versuchsweise ein Zündkabel meines Pkw mit 35 Windungen Draht umwickelt und an den Optokoppler geklemmt. Der Mega wird über ein separates Akku-Pack versorgt. Und es kommt nur noch Unsinn ;( ! Eine Anzeige kommt nur zu stande, wenn ich eines der Spulenenden berühre, sonst gibt der µC gleich auf. Und das, was angezeigt wird ist auch nur Mist. Der Optokoppler und der separate Akku sollte doch eingentlich genau dieses verhindern 8( ? Offenbar muss ich den Eingang noch filtern, habe aber keine Ahnung, wie. Sorry, Need Help.

Schmidti
[SIZE=1]...wenn man ganz viele davon durch einen dünnen Draht jagt, kann man es ganz deutlich sehen:
[SIZE=3]Elektronen sind ROT !![/SIZE] [/SIZE] :ok:

2

Montag, 30. April 2007, 11:34

kann es sein, dass Dein Auto Mehrfachzündungen macht? Gibts zumindest bei neueren Fahrzeugen schon...

Das zweite ist die Ankopplung. Der Strom für den Zündfunken ist verhältnismäßig gering (wenige mA), dafür die Spannung recht hoch. Wird also bei 35 Windungen nicht allzu hohe Spannungen geben (kommt auch noch auf den Abschlusswiderstand an). Aber kapazitiv koppelt da dann doch auch einiges rüber.

Von daher: Erstmal Tiefpass filtern, bei geschätzten 20.000 /min Maximal zu messender Drehzahl heißt das maximale Frequenz <500 Hz. Das ist bei 10 kOhm Impedanz rund 100 nF (entsprechend 1ms Zeitkonstante). Ansonsten Überspannungsbegrenzung an den Prozessorport (z.B. Schottky-Dioden nach + und Masse oder Z-Diode).

Schmidti

RCLine User

  • »Schmidti« ist der Autor dieses Themas

Wohnort: Bad Oeynhausen ____MSV Espelkamp____

Beruf: Kfz-Mechanikermeister

  • Nachricht senden

3

Montag, 30. April 2007, 21:35

Hallo Stefan
ich habe meine Schaltung inzwischen etwas verändert ( Danke an Sprut) siehe unten. Leider mit wenig Erfolg. Kanst du mir den Tiefpassfilter und die Beschaltung bitte etwas näher beschreiben ?

Gruß
Schmidti
»Schmidti« hat folgendes Bild angehängt:
  • a.jpg
[SIZE=1]...wenn man ganz viele davon durch einen dünnen Draht jagt, kann man es ganz deutlich sehen:
[SIZE=3]Elektronen sind ROT !![/SIZE] [/SIZE] :ok:

4

Mittwoch, 2. Mai 2007, 11:53

hab die Schaltung mal kurz simuliert (wenn auch nicht mit dem LM358).
10 kHz kommen da locker noch durch die Filterung. Müsstest den 10nF-Kondensator einfach größer machen (z.B. 100...220 nF), dann ist die HF auch schon weg.

Allerdings scheint mir die Ankopplung per Optokoppler und Windung um die Zündleitung nicht optimal zu sein.
(siehe auch hier: http://www.elektronik-kompendium.de/foru…SC&category=all)
http://forum.electronicwerkstatt.de/phpB…_bz450_bs0.html

Das fand ich auch noch interessant:
http://www.gafu.de/elektronik/schaltungen/zsp.html (eventuell in der Navigation über Elektronik und dann "KFZ: Signal von Zündung für Drehzahlmesser" wählen, falls der direkte link nicht klappt)