Lieber Besucher, herzlich willkommen bei: RCLine Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

swessels

RCLine User

  • »swessels« ist der Autor dieses Themas

Wohnort: 31535 Neustadt, in der Woche HH

Beruf: Arbeitsplanung in der Luftfahzeugkomponenten - Instandsetzung

  • Nachricht senden

1

Donnerstag, 5. März 2009, 14:33

µC und Servosignal -- Vorwiderstand erforderlich?

Hallo Zusammen,

eine vielleicht banale Frage:

Wenn ich ein Servo mittels Atmel ansteuere, sollte / muss ich einen Vorwiderstand zwischen µC und Servosignalleitung legen und wenn ja, welchen Wert?

Es geht ohne, aber ich weiss nicht ob ich da nicht evtl. etwas überlaste.

Danke und Gruß,
Stefan

psfoto

RCLine User

Wohnort: Bei Stuttgart

  • Nachricht senden

2

Freitag, 6. März 2009, 11:18

Hallo Stefan

Also mein Atmega liefert bei 5V Versorgung auch ein Ausgangs-Signal mit ~5V. Das dürfte für ein normales Servo kein Problem sein, die meisten können eigentlich auch 6 V ab.

Trotzdem verwende ich immer noch einen 1k-Widerstand am Ausgang. (Und sei es nur, um dumme Verpolungen etwas abzusichern...)

Peter
New Projects:
Comming soon! ;-)

swessels

RCLine User

  • »swessels« ist der Autor dieses Themas

Wohnort: 31535 Neustadt, in der Woche HH

Beruf: Arbeitsplanung in der Luftfahzeugkomponenten - Instandsetzung

  • Nachricht senden

3

Montag, 9. März 2009, 07:06

Hallo Peter,

danke für die Info. Ich werde dann auch mal Widerstände einbauen, primär zur Strombegrenzung.
Wie sieht es mit der Signaldämpfung aus?

Gruß,
Stefan

psfoto

RCLine User

Wohnort: Bei Stuttgart

  • Nachricht senden

4

Montag, 9. März 2009, 09:02

Moin

Hab ich jetzt noch nicht nachgemessen, machte aber noch nie Probleme.
Es fließt ja auch kein nennenswerter Strom.

Peter
New Projects:
Comming soon! ;-)

5

Montag, 9. März 2009, 09:05

Eventuell könnte es zu Problemen bei einem Optokoppler Eingang kommen z.B. Flugregler.
Normale Servos sollte der 1k Widerstand nicht stören.