Lieber Besucher, herzlich willkommen bei: RCLine Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 29. Juni 2010, 21:43

Servoelektronik -> Umbau zum Schalter -Frage-

Hallo zusammen,

ich möchte gerne die Servoelektronik nutzen um 2 Relais anzusteuern.
Im Netz bin ich auf folgende Beiträge gestoßen:

Anleitung zum Bau eines ferngesteuerten Schalters...
Servolektronik lernt forografieren...

Nun möchte ich gerne 2 Relais ansteuern und habe in einem Elektronikhandel folgende Schaltung bekommen, bin mir aber nicht sicher ob ich diese Schaltung richtig verstanden habe, deshalb bitte ich euch um euer Feedback, ob es funktioniert.

Hier erstmal die Schaltung:

Wenn ich den Schalter im Sender in die eine Richtung schalte, liegt ja an der Servo Elektronik (Motor Anschluß) die Plusleitung "unten" (siehe Bild 1 = ein Relais).

Die Diode "D1" verhindert das negative Spannung an das Relais geleitet wird.
Die Diode "D2" verhindert oder minimiert ein Relais brummen.
Die Diode "D3" (im 2ten Bild) verhindert das negative Spannung an das Relais geleitet wird.
Die Diode "D4" (im 2ten Bild) verhindert oder minimiert ein Relais brummen.

Fragen:
Ist das so richtig ?
Habe ich die Dioden richtig angeordnet ?
Wenn das so richtig sein sollte, kann ich dann wie in Bild 2 gezeigt einfach ein zweites Relais anschließen ?

Ich habe die originalen Motor Anschlüsse gemessen und habe festgestellt, das bei der einen Schalterstellung +5V angezeigt werden und bei der anderen Schalterstellung -5V. Deswegen habe ich in Bild 2 einfach den Plus und Minuspol zur Verdeutlichung umgedreht.

Schaltung 1
Schaltung 2

Den einfachen Schalter habe ich soeben erfolgreich auf Kanal1
( Kreuzknüppelschalter) anhand meines Meßgerätes getestet.
Dieser Funktioniert.

Was mir aufgefallen ist:
Bewege ich den Kreuzknüppel in die eine Richtung , löst das Raleis am Ende des Servoweges aus.
Bewege ich den Kreuzknüppel in die andere Richtung, löst das Relais nicht am Ende des Servoweges aus, aber es löst aus, wenn ich den Kreuzknüppel wieder in die Mittelposition bringe. Hm... Da weiß ich jetzt nicht warum...


Ich bin mir auch nicht Sicher, ob die 2 Relais Version funktioniert, von daher warte ich am Besten erstmal euer Feedback ab, bevor mir noch was abraucht... ;-)

Danke schonmal vorab für eure Antworten.
Carson Triple Two Business -> 7,4V - 35Mhz
Walkera 5G4 -> 3,7V - 2.4 Ghz

psfoto

RCLine User

Wohnort: Bei Stuttgart

  • Nachricht senden

2

Mittwoch, 30. Juni 2010, 15:06

Hallo Andrien

Im Prinzip sollte deine Schaltung auch mit beiden Kanälen funktionieren.

Die beiden Dioden 2+4 sind sog Freilaufdioden. Die schützen den antreibenden Halbleiter vor induktiven Spitzen beim Abschalten der Spule.
Wie die jetzt bei dir ein Brummen verhindern, kann ich dir auch nicht sagen.
Wahrscheinlich arbeitet die Servoelektronik motorseitig mit PWM (Pulsweitenmodulation). Dh dein Motor/Relais wird mit Impulsen angetrieben, dein Relais flattert.
Warum das jetzt mit Freilaufdiode besser wird ???
Sie sollte auf jeden Fall rein.

Für die Knüppelstellung hätte ich jetzt mal 2 Kandidaten:
-Trimmung am Sender
-Trimmung an der Servoelektronik
In irgendeiner Stellung steht ja dein Servo-Poti nach der Demontage der Elektronik. Das sollte halt bestenfalls die Mittelstellung sein.
Irgendwie hört sich das auch nach einer großen Hysterese an, aber das gibt sich evtl. wenn du mal die Mittelstellungen gecheckt hast.

Peter
New Projects:
Comming soon! ;-)

3

Mittwoch, 30. Juni 2010, 15:56

Zitat

Original von psfoto
Die beiden Dioden 2+4 sind sog Freilaufdioden. Die schützen den antreibenden Halbleiter vor induktiven Spitzen beim Abschalten der Spule.
Wie die jetzt bei dir ein Brummen verhindern, kann ich dir auch nicht sagen.

Wenn die Spule abgeschaltet wird, versucht sie den Strom aufrechtzuerhalten. Daher die Spannungspitzen. Wenn ich diesen Strom jetzt über die Freilaufdiode ableite, fließt er also länger durch die Spule und sinkt nicht so abrupt.
Wie stark dieser Effekt ist, hängt auch von der Frequenz ab, wäre aber zumindest mal eine Erklärung.

RK

4

Mittwoch, 30. Juni 2010, 22:30

Hallo Peter, hallo Reinhard,

es war der Servopoti :D
Vielen Dank für eure Hilfe, es Funktioniert nun einwandfrei.
Ich habe die 2te Schaltung nun auch augebaut und beide Relais arbeiten einwandfrei. :ok:

Gruß
Andrien
Carson Triple Two Business -> 7,4V - 35Mhz
Walkera 5G4 -> 3,7V - 2.4 Ghz

Elektroniktommi

RCLine User

Wohnort: MK, Sauerland

Beruf: Konstrukteur

  • Nachricht senden

5

Donnerstag, 1. Juli 2010, 14:31

D1 und D3 sorgen für das wechselnde ansteuern der Relais, D2 und D4 schützen die restliche Elektronik vor Induktionsspannungen.
Ein Kondensator parallel zu D2 und D4 mindern ein brummen der Relais.
Die Aufschrift "NICHT BRENNBAR" ist keine Herausforderung!
[IMG]http://www.rclineforum.de/forum/attachment.php?attachmentid=122429&sid=[/IMG]

[SIZE=4]Ströme messen nicht vergessen![/SIZE]

Chilikakaoexperte

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Elektroniktommi« (2. Juli 2010, 10:39)


6

Donnerstag, 1. Juli 2010, 19:51

Hallo Elektroniktommi,

vielen Dank für Deine Erklärung. :ok:
Zwei Kondensatoren wurden soeben hinzugefügt.

Gruß
Andrien
Carson Triple Two Business -> 7,4V - 35Mhz
Walkera 5G4 -> 3,7V - 2.4 Ghz

Elektroniktommi

RCLine User

Wohnort: MK, Sauerland

Beruf: Konstrukteur

  • Nachricht senden

7

Freitag, 2. Juli 2010, 10:39

Ich habe das mit den Kondensatoren korrigiert....müssen parallel zu D2 und D4
»Elektroniktommi« hat folgendes Bild angehängt:
  • schaltung2.jpg
Die Aufschrift "NICHT BRENNBAR" ist keine Herausforderung!
[IMG]http://www.rclineforum.de/forum/attachment.php?attachmentid=122429&sid=[/IMG]

[SIZE=4]Ströme messen nicht vergessen![/SIZE]

Chilikakaoexperte

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Elektroniktommi« (2. Juli 2010, 10:43)