Lieber Besucher, herzlich willkommen bei: RCLine Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

1

Samstag, 3. Juni 2017, 13:06

Transistor C557B durchmessen

Mal ne Transistorfrage.

Ich habe hier einen Solarlader.
Dieser tut leider nicht und ich versuche zu ergründen wieso.
Widerstände und Dioden habe ich durchgemessen.
Die scheinen in Ordnung.

Nun sind dort 2 Transistoren verbaut.
Bezeichnung C557B darunter steht W86.

Nun wäre interessant raus zu bekommen ob die in Ordnung sind.
Wie Messe ich so ein Ding?

Des Weiteren bekomme ich als Neuteil BC557b.
Da steh dann W64 oder irgend was anderes drauf.
Sind die trotzdem Baugleich?

haschenk

RCLine User

Beruf: Dipl. Ing.

  • Nachricht senden

2

Samstag, 3. Juni 2017, 17:37

Hallo Joshy,

der C557B ist ein PNP-(Silizium-) "Feld-Wald-und Wiesen"-Transistor, der ein paar Cent kostet. "Prüfen" lohnt sich da nicht, und ich schreib' dafür auch keine Prüfanleitung.
BC557 (mit oder ohne angehängtes "B") ist ein vollwertiger Ersatz. Das "W86" dürfte nach irgendeinem Code für das Herstellungsdatum stehen.

Einzelne Transistoren wirst du kaum wo bekommen, aber versuchs mal bei den üblichen Versendern oder bei Ebay; da gibt's dann (geschätzt) 20 Stk. für 1 Euro.... Der Versand wird mehr kosten, außer "free shipping" beim Ebay-Chinesen.

Wichtig vor dem Auslöten:
Das Transistorgehäuse hat eine abgeflachte Seite, diese dient zur Orientierung/Identifizierung der 3 Beinchen. Mach' dir zuerst eine Skizze, wo welches Beinchen in die Platine reinkommt.
Und wenn dich jemand fragen sollte: Der Ersatz muß ein PNP-Typ sein; das ist (extrem laienhaft gesagt) ein "umgekehrt gepoltes Gegenstück" zu den mehr verbreiteten NPN-Typen.

Gruß,
Helmut

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

3

Sonntag, 4. Juni 2017, 13:12

Danke für Info.


Grundsätzlich weis ich was ein Transistor ist und macht.
Ich hatte jedoch noch nie das Vergnügen sowas reparieren zu wollen.

Problemstellung: den Hersteller des Reglers gibt es nicht mehr.
Der Regler hat laut Spezi 0,1mA Eigenverbrauch. Extrem wenig.
Das Ding kostet Neu 80€.
Die verbauten Bauteile Max 10€. Eher 5€.
Eine Hanvoll Widerstände, 3 Dioden, 2 Transen, 2 Fusen und 2 schwarze Käfer.
Ein Buk11 und ein TL072CP.

Ich habe nun raus wie man die Transen misst.
Einen konnte ich so messen, den anderen musste ich auslöten.
Jeden in 6 Richtungen vermessen.
Ergebnis: beide in Ordnung.

Hier ganz gut erklärt:
http://www.hobby-bastelecke.de/halbleite…istor_pruef.htm

Bis auf einen Widerstand der statt 330M nur 320M aufweist und somit außer der Toleranz wäre sind alle Raupen in Ordnung.
Ich kann mir kaum Vorstellen, dass dies die ganze Regelung Inop macht.

Ich hab mal für 3€ Bauteile bestellt und tausche dann erstmal den BUk11 aus.
Der Ausgang geht an die Bakterie. Zum Laden sollten da 13,8V liegen.
Ich messe unter Last jedoch nur die Hälfte.

Wenn das nix bringt nehm ich den nächsten schwarzen Käfer.

Danach würde ich den Widerstand wechseln.

4

Montag, 5. Juni 2017, 08:56

Es gibt auch einen 2SC557B von NXP.
Das ist ein NPN Typ. Also bitte vorher kontrollieren ob's ein NPN oder ein PNP Transistor ist.

Zum Transistor, wenn's denn nun ein BC557B ist.
Soweit ich weiß gibt der Buchstabe hinter dem Transistor den Stromverstärkungsbereich an.
Also sollte man eine BC557B auch wieder gegen einen B-Typ tauschen.

Gut wär auch ein Schaltplan.
Damit könnte man u.U. den Fehler genuer einkreisen.
Wenn Du Pech hast, tauscht Du alle Bauteile aus, nur um dann zu merken, das eine Leiterbahn unterbrochen war, oder eine Lötstelle kalt.

FET's lassen sich nur relativ schwer durchmessen, wenn sie nicht gleich komplett defekt sind.
Bei defekten FET's tausch ich auch immer die Gate Treiber ( Transistor o.Ä. ) mit, das spart Frust.

Hab auch mal nach BUK11 gegoogelt und kein Match gefunden. Ein BUZ11 ist es nicht? Das ist ne Standard Type!
Welche Spannung hast Du denn zwischen Gate und Source?
Wenn da 8V oder mehr anliegt müsste der FET voll durchsteuern.

Wenn dein 330M Widerstand ein 10% Typ ist, ist er mit 320M immer noch in der Toleranz 330M +/- 5% = 315M...345M.
Zudem wirken sich hier parasitäre Widerstände ( z.B. "Dreck" auf der Leiterbahn ) auf das Messergebnis aus.

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

5

Montag, 5. Juni 2017, 11:51

Ja. Ist ein BUZ11. Da hat mal wieder die Autokorrektur des bekloppten Apple Gerätes zugeschlagen.
Ich hasse den ganzen Apple Mist.

Die Transen sind O.K.
Leiterbahnen habe ich komplett durchgemessen.

Der Widerstand hat 1% laut Banderole.

Schaltplan leíder Fehlanzeige. Im Netz ist auch keiner zu finden.
Allerdings ist die Platine sehr aufgeräumt.

Zwischen Source und Drain scheint durchgeschaltet zu sein.
Da liegt nach heutiger Messung die volle Batteriespannung an.
( Da habe ich gestern vermutlich falsch gemssen.
Statt and der Batteriemasse an der Solarzellenmasse...)
Am Gate 2,38V.

Ich bin kein Elektroniker. Was macht der BUZ11?
Kann der die Spannung erhöhen oder kann der nur die Spannung vermindern?
Oder nur durchlassen?

Ich habe eine Erklärung gefunden die sagt, dass am Gate 10V mehr sein müssen als an der Source.
Dann würde so ein Bauteil durchschalten.
Nun habe ich am Gate 2,38V, am der Source 12,4V, am Drain auch 12,4V.
Ausgebaut ist er vom Source zum Drain gemssen niederohmig.
Vom Drain zum Source gesperrt.

Löte ich den Drain ab habe ich 2V am Source.
Löte ich ihn an habe ich 12,4V am Source.
Also steuert das Teil vom Source zum Drain durch.
( Oder die Schaltung macht zufällig, dass auf der Platine dann 12,4V generiert werden. Unwahrscheinlich... )
Das ist nicht richtig, oder?
Ich habe das Bauteil so verstanden, dass es vom Source zum Drain sperren sollte.

kalle123

RCLine User

Wohnort: Mönchengladbach

  • Nachricht senden

6

Montag, 5. Juni 2017, 12:26

Es bietet sich doch an, mal ein paar Bilder des Laders hier einzustellen.

Sind da Elkos drauf?

Gruß KH

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

7

Montag, 5. Juni 2017, 12:49

Nein. Keine Elkos.

Ich habe in der Spez der BUZ11 gefunden:
Gate Threshold Voltage 2,1V max 4.
Da bin ich dann einem Fehler aufgesessen vermute ich.
2,1V braucht das Ding am Gate damit von der Source zum Drain geschaltet wird.
Da würden die 2,38 reichen. Macht er auch.
Wenn ich das Gate ablöte gehen die 12,4 trotzdem vom Drain zum Source.
Ich habe erwartet, dass dann gesperrt wird.
Da ist evt. was faul.
»JoshyJS« hat folgende Bilder angehängt:
  • IMG_20170605_1241281.jpg
  • IMG_20170605_1240461.jpg

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »JoshyJS« (5. Juni 2017, 13:18)


8

Montag, 5. Juni 2017, 21:58

Der BUZ11 ist ein FET.

Der hat ne parasitäre Diode zwischen Source und Drain.
Legt man da + auf Source und - auf Gain wird man da so etwa 0,5V Spannungsabfall messen.
Ich nehm da immer die Diodentestfunktion meines Multimeters.

Auch wenn man das Gate des FET ablötet kann dieser immer noch durchgesteuert sein.
Der Grund: Das Gate hat praktisch keine leitende Verbindung zu den anderen Anschlüssen des FET.
Wohl aber einen parasitären Kondensator zwischen GATE und den anderen Anschlüssen.
Sind diese aufgeladen steuert der FET trotz abgelötetem Gate durch.

Um sicher zu gehen müsste das abgelötete Gate mit einem Widerstand mit SOURCE verbunden werden.
Dann muß der Transistor sperren!

Noch was:
Ich würde Dir empfehlen die Leiterplatte etwas pfleglicher zu behandeln.
Es sieht so aus, als hättest Du den FET ohne die Lötstellen zu erhitzen von der Leiterplatte abgerissen.
Eine Leiterbahn schaut bereits zerstört aus und müsste geflickt werden.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wkrug« (5. Juni 2017, 22:06)


9

Dienstag, 6. Juni 2017, 08:21

Noch was:
Ich hab mir gestern das Layout noch etwas angeschaut.
Soweit ich das gesehen haben ist in dieser Schaltung nicht der - Pol der Batterie der Bezugspunkt, sondern der Pluspol der Batterie ist mit + der Solarzelle verbunden.
Der FET hängt anscheinend zwischen der Batterie und dem Minuspol der Solarzelle - Was bei einem N-Kanal Fet auch Sinn macht.
Die beiden Sicherungen am Eingang hast du gecheckt? Sollten beide voll durchgehen.

Wenn Du keinen Schaltplan hast würde ich das Bild vom Layout Spiegeln und mir dann zusammen mit der Bestückung einen Schaltplan rauszeichnen.
Ist zwar eine aufwändige Arbeit, kann Dir aber viel weiterhelfen.

!!! Achtung Vermutung !!!
Der FET wird anscheinend in dieser Schaltung nicht als Schalter, sondern als regelbarer Widerstand eingesetzt, der in Zusammenarbeit mit der restlichen Schaltung die maximale Ladespannung der Batterie begrenzt.
Die Strombegrenzung wird anscheinend nur durch die maximale Leistung des Solarpanels begrenzt, das IMHO nicht mehr als 12W haben dürfte.

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

10

Dienstag, 6. Juni 2017, 10:58

Moin,

Die Leiterbahn ist da wurscht. Habe ich schon gesehen. Wird wieder mit angelötet.
Oder an anderer Stelle. Das ist eine Standard Platine aus der die 3 verschiedene Regler gebaut haben.
Da können mehrere Batterien beschickt werden. In meinem Fall nur eine.
Daher auch nur ein FET. Bis zu 3 sind einbaubar.

Die Panel dahinter können bis zu 16W haben. Das verbaut der Hersteller so. 2x8.
Meines hat keine 6W. Das spielt nicht so die Geige.

Ich habe alles durchgemessen.
Es bleiben nur die beiden schwarzen Käfer.

Solarzellenanschlüsse sind außen.
Batterie ist innen angeklemmt.

11

Dienstag, 6. Juni 2017, 11:52

Zitat

Es bleiben nur die beiden schwarzen Käfer.

Wenn nur die noch bleiben, tausch sie aus! Kosten ja nur ein paar Cent.

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

12

Dienstag, 6. Juni 2017, 14:38

Bin dabei. Leider sind die noch nicht da.

haschenk

RCLine User

Beruf: Dipl. Ing.

  • Nachricht senden

13

Dienstag, 6. Juni 2017, 18:04

Hallo,

Zitat

Wenn Du keinen Schaltplan hast würde ich das Bild vom Layout Spiegeln und mir dann zusammen mit der Bestückung einen Schaltplan rauszeichnen.
Ist zwar eine aufwändige Arbeit, kann Dir aber viel weiterhelfen.

Dazu würde ich auch raten. Ich schätze mal 2 - 3 Stunden bis zu einer vernünftigen "Reinskizze". Es sind ja nicht viele Teile, und alles recht groß. Dann weiß man, wie das Teil funktioniert...
Ich halte zu so einem Re-Engineering auch oft die Platine vor eine Lichtquelle, sodaß die Leiterbahnen durchscheinen.

"BUK11" gibt's wirklich, wusste ich auch nicht, aber Google weiß es... Noch mit einer oder mehr Ziffern hinter der "11". Ist aber prakt. dasselbe wie BUZ11; N-Kanal Power MOSFET.


Gruß,
Helmut

Nachtrag:
Was steht denn auf dem IC (DIL8-Gehäuse) neben dem Spindelpoti ? Da in dessen Umgebung kein Kondensator zu sehen ist, tippe ich eher darauf, daß es ein (Dual- ?) OpAmp ist.
Gibt es Infos dazu, wie der Regler eingesetzt wurde ? Laden von Bleiakkus (12V ?) aus Solarpanel (Spannung, Strom) ?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »haschenk« (6. Juni 2017, 18:49)


14

Dienstag, 6. Juni 2017, 20:11

Zitat

"BUK11" gibt's wirklich, wusste ich auch nicht, aber Google weiß es... Noch mit einer oder mehr Ziffern hinter der "11". Ist aber prakt. dasselbe wie BUZ11;

Seh ich nicht so.
Einen BUK11 hab ich nicht gefunden. Wenn Du den Links folgst findest Du BUK11x Typen.
Die BUK11x sind meistens Logic Level Typen und somit von der Funktion her etwas anders als der BUZ11.

Aber das mal nur Informativ.

Wenn Joshy Pech hat funktioniert die Schaltung auch nach dem Tausch der "schwarzen Käfer" nicht.
Auch wenn ich selber schon defekte Op-Amp's hatte.

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

15

Mittwoch, 7. Juni 2017, 11:15

Ist ja auch nur ein Hobbyversuch.

Also: bei meinem Verständnis von Schaltplänen würde ich auch mit einme Plan nicht mehr kapieren.
Ich kann so ein Ding nachbauen und anscheinend auch nachmessen.
Warum das alles funktioniert: keinen Plan.

Ich hoffe die Teile kommen heute.

Leider heute nicht gekommen. Pustekuchen mit Conrad Expressbestellung.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »JoshyJS« (7. Juni 2017, 12:48)


JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

16

Mittwoch, 7. Juni 2017, 23:35

Ich habe mal gezeichnet...
»JoshyJS« hat folgendes Bild angehängt:
  • plan.jpg

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

17

Donnerstag, 8. Juni 2017, 21:00

Berichtigung

Es fehlte noch eine Leitung.
Ausserdem handelt es sich um zwei Zener- und eine Leistungsdiode.
An den schwarzen Käfern lag es anscheinend auch nicht.
Ich habe einen Sockel eingelötet um die Steine schneller tauschen zu können.
Alte und neue TL72 bringen das gleiche Ergebnis.
Der BUZ11 schaltet.

Bei 19V als Solarzellensimulation komme ich bei 11,7V Batteriespannung im Moment auf 6mA Ladestrom.
Ein wenig ernüchternd.

Also entweder irgendwas mit den Dioden oder dem Regelwiderstand.
Habe ich natürlich beide nicht...
»JoshyJS« hat folgendes Bild angehängt:
  • Regler2.jpg

18

Donnerstag, 8. Juni 2017, 21:21

Also irgendwie fehlt mir da eine Verbindung vom Solarpanel zum BUZ11.
Auf dem Bestückungsaufdruck ist da ein Leistungswiderstand drin.
Der sollte IMHO eigentlich bestückt sein und als Strombegrenzung dienen.
Eventuell war das ja auch nur ein aufgewickelter Widerstandsdraht?!

JoshyJS

RCLine User

  • »JoshyJS« ist der Autor dieses Themas

Beruf: Flugzeugmechaniker, Verkehrsflugzeugführer

  • Nachricht senden

19

Donnerstag, 8. Juni 2017, 22:37

Ehrlich gesagt: Gedacht habe ich das auch schon...
Laut dem Bestückungsaufdruck sollte es eine Diode sein, Kein Widerstand.
Da steht D6. Könnte auch ne Zener sein.

Allerdings ist die Platine dazu da da drei verschiedene Regler draus zu bauen.
Das wird nicht alles bestückt sein müssen.
Es sind Anschlüsse für 3 BUZ auf der Platine.

Plus von 12V und 18V liegen gemeinsam.
Masse ist jeweils eigen.

Ich nahm an das +18V geht in die Schaltung, durch den Baustein und kommt als Ladespannung aus dem BUZ.
Macht es aber nicht.
Falls die 18V gebrückt auf den Drain des BUZ gehen... Wie wird dann geregelt?
Dann verbinde ich die 18V Solarspannung direkt an die 12V Batterie.
Kann nicht gesund sein...

Da war noch ein Fehler in meiner Zeichnung.
Anbei Rev 3.0

@Helmut
Ich kenne noch ein System bei dem es mit gleichem Regler funktioniert.
Allerdings hat dieser Regler da auch nicht getan.
Erst ein Ersatzregler hat da gemacht. Allerdings habe ich den Funktionierenden nicht geöffnet.
Er ist leider auch nicht greifbar da 60km weg.
Ladestrom mit den beiden 8W Panels geht bis 1,5A.
Auf dem Käfer steht TL072CP.
»JoshyJS« hat folgendes Bild angehängt:
  • Regler3.jpg

20

Freitag, 9. Juni 2017, 02:24

Da sind noch ein paar Fehler drin.
1. Die Diode ( 1N4007 ) am linken BC557 ist falsch rum eingezeichnet ( Der weisse Ring ist die Kathode ).
2. Bei beiden BC557 ist Kollektor mit Emitter vertauscht - Das kann eventuell auch Herstellerabhängig sein!!!
3. Am 2ten OP geht vom Ausgang Pin 7 noch ein Widerstand zur Basis des rechten BC557.
4. Ein Widerstand geht anscheinend noch von Pin 7 des OP gemeinsamen +.
5. Die Anzahl der Widerstände würde ich noch mal mit dem Schaltplan überprüfen - Scheint nicht zu stimmen.

Funktion:
Wenn die Solarspannung >als ca. 14,5V wird leitet die 13V Z-Diode und der Transistor links legt die Stromversorgung ( 13V ) auf die Elektronik an, solange das Panel Licht hat.

Die Z-Diode links neben VCC- Pin 4 des OP ist anscheinend die Referenz. Da sollten dann 6,2V gegen VCC- anliegen.

Ladeschaltung: Solange die Spannung vom Poti her kleiner ist als diese 6,2V wird die Basis des rechten BC557 über den Widerstand nach GND gezogen.
Er leitet also und steuert seinerseits den FET an.
Dieser verbindet dann über den nicht eingebauten Widerstand das Solarpanel mit der Batterie und lädt diese.

Akku voll: Der andere OP auf Pin 2...4 ist ein reiner Komparator.
Wenn die Spannung vom Trimmer her >als die Referenzspannung ( 6,2V ) ist, schaltet der Ausgang nach -VCC und die LED "Akku voll" leuchtet.
Er arbeitet also genau umgekehrt wie der OP-AMP auf Pin 5...7.

Meine Meinung: Das Panel darf IMHO nicht direkt mit der Source des FET verbunden werden.
Geht man von einer minimalen Spannung der Batterie von 11,1V aus und das Panel würde 18V machen müsste der Widerstand 6,8 Ohm haben, bei einer Belastbarkeit von mindestens 7W.
Da das Panel bei Belastung auch etwas zusammen brechen wird, kann der Wert u.U. auch etwas kleiner sein.

Meiner Meinung nach kann das Ganze ohne diesen Widerstand nicht funktionieren.

Eventuell war er ja auf einen Kühlkörper geschraubt und mit Drähten mit der Platine verbunden?! Und wurde zum Ausbau der Platine abgelötet.

Wenn möglich, lass das funktionierende Gerät mal aufschrauben und Dir ein Foto zuschicken!
Dann kennst Du auch den Wert des Widerstandes.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »wkrug« (9. Juni 2017, 02:32)


Ähnliche Themen